TLS v 1.1 Deprecation for SOAP/REST & API messaging services access.

Security is at the heart of PageOne messaging services. In line with industry standards and best practice we will be withdrawing support for the older SSL/TLS v1.1 protocol and associated cipher suites by 30th September 2020 on our messaging API’s

From 30th September 2020 PageOne will only support TLS v1.2 or higher, together with optimised cipher suites using secure EC (Elliptic Curve) ciphers on our messaging API’s.

What does it mean for me?

If you access PageOne services via www.pageone.co.uk or www.oventus.com from a browser you are unaffected by this change, as these services already only support TLS v1.2.

However, if you use PageOne REST or SOAP API services via third party software systems you may need to update your systems security configuration to operate at TLS 1.2.

Most clients who had previously upgraded their security configuration as a result of the TLS v1.0 deprecation have already upgraded to TLS v1.2 or higher, and thus will be unaffected.

Please contact our Customer Support team via customersupport@pageone.co.uk or 0333 200 5033 if you experience any issues as a result of the above security change.

Leave a Reply